3D Axes - MDL Application for MicroStation - When to use

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

MP 3D Axes - зачем и когда его использовать

Разрабатывая любой двухмерный чертеж, который содержит в себе оси - будь то, например, оси детали машины, здания или трубопроводной системы, очевидным решением всегда было просто нарисовать эти оси прямо на чертеже.
При работе в трехмерном пространстве (сложно представить для этого лучшую среду, чем MicroStation) первым, что приходит в голову для использования осей - это применить такой-же подход - просто нарисовать оси.

Однако при подобном подходе начинают возникать некоторые сложности и неудобства.
Просто отрисованные оси в виде линий уже не соответствуют тому - что представляет из себя ось в модели.
Для опытных инженеров очевидно, что ось в трехмерном пространстве - это скорее некая плоскость, которая должна отображаться при пересечении видового пространства под прямым углом.

Возникает вопрос - есть ли возможность отобразить это в трехмерном пространстве MicroStation?
Как сделать так, чтобы трехмерные оси вели себя так как им полагается?

Решить эту задачу призвано описываемое здесь приложение!

3D Axes - модуль для MicroStation, позволяющий работать с 3D моделью любых систем, имеющих оси, не заботясь об их отображении.

Например, есть здание с определенной системой осей:

При использовании нашего приложения в модели оси выглядят следующим образом, например, для вида сверху (Top)

Приложение MP 3D Axes призавно сделать так, чтобы трехмерные оси отображались тогда, когда они нужны, не мешались тогда, когда их присутствие не требуется. Оси также несут в себе информацию и при необходимости отображают ее, есть возможность привязываться к ним.

Разработчики программы прикладывают все усилия, чтобы работа с осями была максимально удобной и быстрой. Для нас очень важна обратная связь. Надеемся, что добиться полного соответствия трехмерных осей своему назначению поможет каждый инженер, который попробовал программу, высказав свои замечания и предложения!


3D Axes - MDL Application for MicroStation - New features

MP 3D Axes
 | Назначение
- | Возможности
 | динамическое отображение
 | привязки
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

MP 3D Axes - возможности

Каждая ось отображается, если ее плоскость становится перпендикулярной области отображения. Это может быть плоскость вида или плоскость изометрии.

Сами оси не хранятся в файле MicroStation, с ними нельзя проводить операции как с обычными элементами. Проще говоря, их вообще нельзя "поймать", и тем более случайно удалить.

Каждая ось несет в себе информацию, которая отображается динамически в метках и подсказках

Ситемы осей могут быть

  • ортгональными - используются три координаты - X,Y,Z
  • радиальными - используются радиус, угол и координата Z

Есть возможность использовать привязки в полном объеме

  • Пробная точка (Tentative point)
  • AccuSnap
Отображение осей при поворотах вида:
подробнее
MP 3D Axes v2 - axes depending on view rotation
AccuSnap и радиальные оси:
подробнее
MP 3D Axes v2 - AccuSnap and radial axes


3D Axes - MDL Application for MicroStation - New features

MP 3D Axes
 | Назначение
- | Возможности
 | динамическое отображение
 | привязки
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

MP 3D Axes - возможности

Как выглядит работа программы при повороте видов...
(с использованием стандартного иснтрумента Change View Rotation):

MP 3D Axes v2 - how it works...


3D Axes - MDL Application for MicroStation - New features

MP 3D Axes
 | Назначение
- | Возможности
 | динамическое отображение
 | привязки
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

MP 3D Axes - возможности

Операции с объектами с использованием AccuSnap и радиальных осей:

MP 3D Axes v2 - using AccuSnap with radial axes


3D Axes - MDL Application for MicroStation - Main dialog

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

Главная панель инструментов

MP 3D Axes axes main dialog

Для вызова спользуется команда: 3DAXES TOOLBOX

На главной панели используются следующие кнопки:

Select 3D Axes File | - | загрузка координат осей из файла CSV команда: 3DAXES ADDFILE
3D Axes Settings | - | диалоговое окно, позволяющее настраивать различные параметры работы приложения команда: 3DAXES SETTINGS
Show Axes Tooltips | - | включает/выключает интерактивные подсказки к осям
Show Axes Labels | - | включает/выключает отображение имен осей
Show X Axes | - | показать/скрыть оси по координате X
Show Y Axes | - | показать/скрыть оси по координате Y
Show Levels | - | показать/скрыть оси по координате Z (отметки)
Show Rays | - | показать/скрыть лучевые оси радиальной системы
Show Arcs/Circles | - | показать/скрыть круговые оси радиальной системы

Кроме того, возможно использовать такие команды:

3DAXES EXIT - выгрузка приложения из MicroStation

3DAXES VERSION - выводит информацию о версии модуля

3DAXES HELP - вызывает помощь


3D Axes - MDL Application for MicroStation - Settings dialog

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

Диаоговое окно настроек

Используется команда: 3DAXES SETTINGS

Общие настройки:

MP 3D Axes axes settings - axes style

Color - определяет цвет осей

Main style - определяет стиль линий основных осей

Auxiliary - определяет стиль линий вспомогательных осей

Use active origin - определяет – использовать для абсолютного центра координат нулевую точку файла, которая всегда без изменений или Active Origin, которая может меняться по указанию пользователя

Show axes labels - опция определяет, будут ли отображаться названия осей

Axes overhang - данное значение - дистанция от окончания линии оси до ближайшей перпендикулярной ей оси

Axes view depth - определяет, на какой глубине вида отображаются оси
(в настоящий момент в разработке)

Настройки подсказок:

MP 3D Axes axes settings - tooltips

Delay - определяет интервал времени в секундах, через который появится подсказка к оси, после того как курсор окажется рядом с осью (понятие «рядом» определяется текущей настройкой Tolerance). При привязке к оси (описание привязок см. ниже) подсказка появляется сразу вне зависимости от значения Delay.

Axis prefix - показывать тип оси перед ее названием, тип оси может определяться пользователем

Axis name - показывать имя оси, определенное во второй ячейке файла настроек (для отметок используется стандартное обозначение координаты)

Parent axis name - показывать имя оси, определяющей для данной оси начало отсчета координат (родительской оси)

Axis coordinate - показывать координату оси такой, как она прописана в файле настроек

Global axis coordinate - показывать глобальную координату оси, используемую для ее отображения

Distance from left or lower - показывать расстояние для ближайшей левой или нижней оси

Distance from right or upper - показывать расстояние для ближайшей правой или верхней оси

Comment - показывать комментарий

Список загруженных систем:

MP 3D Axes axes settings - system list

Add button - кнопка, которая позволяет добавить очередную систему осей для отображения

Remove button - кнопка удаляет систему осей из списка

Show system - опция, определяющая - показывать или нет систему осей


3D Axes - MDL Application for MicroStation - Coordinates file format

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
+ | Пример

Формат данных в файле системы осей

Все координаты используют Master Units.

В секциях [X], [Y], [Z], [Rays], [Arcs] используется следующий формат строки:

  • ID оси (может быть пустым если ось не используется как исходная для отсчета координат других осей)
  • ID родительской оси (ссылка на ID оси, если пусто, то используется точка отсчета в секции [Origin])
  • Label - наименование оси, отображаемое на видах
  • Координата для обычных осей, для круговых радиальных - радиус, для лучевых радиальных - угол в градусах
  • Атрибуты, разделенные запятой:
    inv - ось невидима
    iso - координата оси используется для показа системы в изометрических видах
  • Комментарий (для отображения в подсказках)

Например:

Пример файла CSV

MP 3D Axes axes - data format sample

Заголовки данных осей:

ustation 3daxes coord file v2 | Первая строка файла
[Origin] | Центральная точка системы, используемая для отсчета координат осей
[Rotation] | Угол поворота системы осей относительно оси Z и центральной точки
[Direction] | Направление радиальной системы осей, или начальный угол отсчета для всех радиальных лучевых осей
[Overhang] | Выступ осей - расстояние от конечной точки оси до ближайшей перпендикулярной оси
[X] | Оси с координатой по оси X
[Y] | Оси с координатой по оси Y
[Z] | Оси с координатой по оси Z (отметки)
[Rays] | Лучевые радиальные оси
[Arcs] | Круговые радиальные оси

Содержимое файла системы осей, если его открыть в текстовом редактре, выглядит примерно так:
ustation 3daxes coord file v2

[Origin] (x,y,z)
500;1000;1500

[Rotation] (degrees)
30

[Direction] (degrees)
60

[Overhang] (value)
1800

[X] (id;parent id;label;coordinate;attributes;comment)
;;A;0;;
;;B;1000;;
;;C;2000;;
;;D;3000;;

[Y]
;;1;0;;
1;;2;2000;;node axis
;1;3;2000;;counting out from axis 2, which id=1
;;4;6000;;

[Z]
;;-2.000;-2000;;
;;-1.000;-1000;;
;;0.000;0;iso;
;;+2.000;2000;;
;;+3.000;3000;;

[Rays]
;;RA;30;inv;
;;RB;75;inv;
;;RC;145;;
;;RD;200;;

[Arcs]
;;AA;3000;inv;
;;AB;3500;;
;;AC;4000;;
;;AD;4500;;
;;AE;5000;;
;;AF;5500;inv

Рекомендуется использовать Microsoft Excel или OpenOffice для редактирования файлов.
Выглядеть это может примерно так:

MP 3D Axes axes - CSV file - entering data


3D Axes - MDL Application for MicroStation - Detailed example

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
- | Пример
 | Первый шаг
 | Шаг 2
 | Шаг 3
 | Шаг 4
 | Шаг 5
 | Шаг 6

Подробный пример создания простой системы осей

Первый шаг

Введите первую строку - заголовок "ustation 3daxes coord file v2"
Если этот заголовок отсутствует, файл прочитан не будет.

Введите данные для следующих заголовков:
[X], [Y], [Z]
(Любые данные после символа ']' игнорируются)

Введите координаты X, Y, Z и другие данные для осей.

Обратите внимание на атрибут iso (line 21). Он означает, что все оси в [секции] будут отрисовываться в изометрических видах в плоскости с координатой данной оси.

В текущей версии (8.2.0.1) поддерживается только один уровень для изометрии с координатой по Z.

MP 3D Axes detailed example - first steps

Система осей после запуска приложения (размеры для информации)

Нажмите на изображение для того чтобы увидеть все виды

MP 3D Axes detailed example - simple axes system

Шаг 2
Шаг 3
Шаг 4
Шаг 5
Шаг 6


3D Axes - MDL Application for MicroStation - Detailed example

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
- | Пример
 | Первый шаг
 | Шаг 2
 | Шаг 3
 | Шаг 4
 | Шаг 5
 | Шаг 6

Подробный пример создания простой системы осей

Первый шаг
Шаг 2

Введите данные для точки отсчета координат

MP 3D Axes detailed example - entering axes system origin

Система осей после запуска приложения (размеры для информации)

Нажмите на изображение для того чтобы увидеть все виды

MP 3D Axes detailed example - axes system origin

Шаг 3
Шаг 4
Шаг 5
Шаг 6


3D Axes - MDL Application for MicroStation - Detailed example

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
- | Пример
 | Первый шаг
 | Шаг 2
 | Шаг 3
 | Шаг 4
 | Шаг 5
 | Шаг 6

Подробный пример создания простой системы осей

Первый шаг
Шаг 2
Шаг 3

Введите данные для расстояния "выступа" осей.
Это значение будет переопределять значение, действующее по умолчанию для всех осей (определенное в диалоговом окне настроек)

MP 3D Axes detailed example - entering axes overhang

Система осей после запуска приложения (размеры для информации)

Нажмите на изображение для того чтобы увидеть все виды

MP 3D Axes detailed example - using axes overhang

Шаг 4
Шаг 5
Шаг 6


3D Axes - MDL Application for MicroStation - Detailed example

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
- | Пример
 | Первый шаг
 | Шаг 2
 | Шаг 3
 | Шаг 4
 | Шаг 5
 | Шаг 6

Подробный пример создания простой системы осей

Первый шаг
Шаг 2
Шаг 3
Шаг 4

Введите данные для поворота системы осей.
Поворот происходит относительно оси Z и точки,
определенной в секции начала координат [Origin]

MP 3D Axes detailed example - entering axes system rotation

Система осей после запуска приложения (размеры для информации)

Нажмите на изображение для того чтобы увидеть все виды

MP 3D Axes detailed example - axes system rotation

Шаг 5
Шаг 6


3D Axes - MDL Application for MicroStation - Detailed example

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
- | Пример
 | Первый шаг
 | Шаг 2
 | Шаг 3
 | Шаг 4
 | Шаг 5
 | Шаг 6

Подробный пример создания простой системы осей

Первый шаг
Шаг 2
Шаг 3
Шаг 4
Шаг 5

Введите данные для радиальных осей.
Здесь мы также установим атрибут inv для некоторых осей X, Y.
В результате эти оси будут невидимыми.

MP 3D Axes detailed example - entering radial axes data

Система осей после запуска приложения (размеры для информации)

Нажмите на изображение для того чтобы увидеть все виды

MP 3D Axes detailed example - radial axes

Шаг 6


3D Axes - MDL Application for MicroStation - Detailed example

MP 3D Axes
 | Назначение
+ | Возможности
 | Инструменты
 | Настройки
 | Формат данных
- | Пример
 | Первый шаг
 | Шаг 2
 | Шаг 3
 | Шаг 4
 | Шаг 5
 | Шаг 6

Подробный пример создания простой системы осей

Первый шаг
Шаг 2
Шаг 3
Шаг 4
Шаг 5
Шаг 6

Введите данные для направления исходного угла радиальной системы осей.

MP 3D Axes detailed example - entering direction of axes system

Система осей после запуска приложения (размеры для информации)

Нажмите на изображение для того чтобы увидеть все виды

MP 3D Axes detailed example - using direction of axes system